9.5.1.2 optimizer appears to cause xsl:result-document to not write documents

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

9.5.1.2 optimizer appears to cause xsl:result-document to not write documents

Graydon
Hello all --

I really hope this is something simple and obvious which I'm neglecting.

If I run a (large, complicated, splits a big document at the end) group of stylesheets in oXygen 15.1 using Saxon-EE 9.5.1.2, I get the expected behaviour; the big transformed document splits into the expected files.  oXygen is setting the optimization level to 10.

If I run this same input from the command line, I don't get all of the expected result documents.  I get the created-as-we-go along image object documents created in response to particular input element, but I don't get the results of "run the split step on this big document in a variable".  The result document, however, reflects the operations involved in emitting all the individual documents; it's a tiny file with a single pointer to the top of the structured produced by splitting, rather than a single large file.

If I set -opt:10 at the command line, same thing.

If I set -opt:0 at the command line, I pile into various code-complaints that cause transformation to fail.  

If I set -opt:0 with a much smaller input file, without the processing issues when the optimizer is turned off, I get the expected (precisely 1 in this case) split-at-the-end document.

If I don't set -opt or if I set -opt:10 with that much smaller input file, I don't get the expected split-at-the-end document, but the result document goes right on looking as though this document has been subtracted from it in the expected way.

Is there a way to insist that the optimizer always produces a document for xsl:result-document?

Thanks!
Graydon